PowerPC and Old Versions of Mac OS

October 25, 2013

Is anyone still using a PPC mac for music making?

I’m +RIGHT+ on the verge of killing PPC support. Would anyone notice if I did this?
Also, how old a version of Mac OS is anyone using? It’s becoming increasingly difficult (because Apple push pretty hard) to support really old versions.
Currently our oldest supported spec is PPC with OS 10.4.
I am thinking of moving this to Intel 10.5

** Is anyone using OS 10.4?
** Is anyone using PPC?

Let me know!

7 Responses to “PowerPC and Old Versions of Mac OS”

  1. You should definitely ask on Twitter/Facebook, but yes the time must come to move on. I know one or two producers have stuck with older OS so they can use older versions of Logic.

  2. I think a lot of people are going to be shocked by how few audio pros are upgrading their computers and operating systems. Pro Tools 7HD is still common in multi-million dollar studios.

    It’s a very mature market and most changes over the past five years have only improved a few things while degrading others. It’s no longer like the ’90s when a significant performance improvement became available every two or three years.

  3. kill it with fire

  4. It’s a double edged sword! If you drop support for older MAC OS you will face many losses in terms of sales because not all people in this world can afford it to buy a new Mac every 1 or 2 years, nor download heavy updates!

    Sad to see that most developers have chosen to drop support for MAC OSX 10.5.8, to me it’s still a very stable operation system, regardless of the hype that media are creating about the “new” Macs. If it works good – it IS good!

  5. I’ve decided. I’m keeping 10.5, but ditching 10.4 and PPC.

    Reasons:
    – Even though the DSP is fast, using the UI of any of my stuff on PPC would be sluggish and a suboptimal experience.
    – Between 10.4 and 10.5 windowing stuff changed for the better. On 10.5 my code is neater and faster.
    – With 10.5 I can move to Xcode 4/5 and use the optimisations in the latest compiler.
    – With 10.5 I can use the new signed package format consistently and things work well.
    – I’m no longer prepared to try and keep a PPC mac running for support. It’s just a little too far.

    10.5+ and intelmac feels like a good minimum requirement, and users on ppc/10.4 can grab (much) older installers.

  6. I would keep the PPC compatible versions available.

    That said, recent developments in the malware world and the fact that Apple is dropping security fixes for anything earlier than the current Mavericks version changes the equation for anyone seeking to do serious professional work with an older system.

  7. dmgaudio.com/dl

    All versions ever, available for your enjoyment :)

Leave a Reply